[시스템] Redhat7.1+scsi aic7xxx 문제 해결

Redhat 7.1 install 시 aic7xxx scsi controller 문제 해결..

문제 1) 설치시 Loading aic7xxx….  상태에서 멈추는 현상.

http://people.redhat.com/dledford/440gx/boot.img

http://people.redhat.com/dledford/440gx/bootnet.img

http://people.redhat.com/dledford/440gx/pcmcia.img

에서 부팅 이미지를 다운 받고..이 이미지 파일로 부팅디스켓을 만든다.

# fdformat /dev/fd0

# dd if=boot.img of=/dev/fd0

설치 부팅 디스켓을 넣고..부팅..

# boot : linux apic

하면..무사히 설치 된다.

문제 2) 설치후 시스템 시작시 loading the aic7xxx module 부분에서

<4>scsi : aborting command due to timeout : pid 0, scsi0, channel 0, id 1, lun

0 0x12 00 00 00 ff 00

<4>scsi : aborting command due to timeout : pid 0, scsi0, channel 0, id 1, lun

0 0x12 00 00 00 ff 00

<4>scsi : aborting command due to timeout : pid 0, scsi0, channel 0, id 2, lun

0 0x12 00 00 00 ff 00

<4>scsi : aborting command due to timeout : pid 0, scsi0, channel 0, id 2, lun

와 같은 에러가 계속 반복 되는 현상.

이는 process number 에 관련된 문제이다.

보드가 dual board 고 process number 가 1개 일때 기본적으로 kernel 은

2 process 로 설치가 된다. 그렇기 때문에 위의 문제가 발생하게 된다.

해결방법은 설치과정에서 packege select 에서 kernel-smp 를 추가 설치하도록

한다. 그런뒤 ..설치가 완료되고…부팅시…

# linux-smp

로 부팅하도록 한다.

그럼..된다. 아래는 문제 2) 의 버그 리포트 내용이다. 참조하길 바란다.

From Bugzilla Helper:

User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

virtual terminal alt-f4 shows

SCSI host 0 channel 0 reset (pid0) timed out -trying harder

SCSI bus is being reset for host 0 channel 0.

Reproducible: Always

Steps to Reproduce:

1.Boot off Disc1 of Wolverine

2.

3.

Actual Results:  Hans on install loading aci7xxx module

Expected Results:  continued on with installation

This doesn’t happen when I install Fisher. Seems like maybe a newer

version of the aic7xxx module is causing the problems.

Additional comment by msf at

redhat.com 2001-02-26 11:31:50

Appears to be a kernel issue.

Additional comment by dledford

at redhat.com 2001-02-26 13:53:56

I need to know what hardware you have in your system to be able to help out at

all.  I also need you to switch over to VT4 (by pressing ALT-F4) when the system

says it is loading the aic7xxx module and tell me what you see there.

Additional comment by glen at

redhat.com 2001-02-26 18:17:24

Doug, is this a dup of bug 29266?

Additional comment by dledford

at redhat.com 2001-02-26 18:56:48

No, different issues.

Additional comment by rparish at

digitalwebzone.com 2001-02-27 07:37:33

terminal v4 shows:

<4>scsi : aborting command due to timeout : pid 0, scsi0, channel 0, id 1, lun

0 0x12 00 00 00 ff 00

<4>scsi : aborting command due to timeout : pid 0, scsi0, channel 0, id 1, lun

0 0x12 00 00 00 ff 00

<4>scsi : aborting command due to timeout : pid 0, scsi0, channel 0, id 2, lun

0 0x12 00 00 00 ff 00

<4>scsi : aborting command due to timeout : pid 0, scsi0, channel 0, id 2, lun

0 0x12 00 00 00 ff 00

<4>scsi : aborting command due to timeout : pid 0, scsi0, channel 0, id 3, lun

0 0x12 00 00 00 ff 00

so on.. until id 15 then switches to the second scsi chaing scsi1 id0 and so on

until id15then

<4>attached scsi disk sda at scsi0, channel 0, id 0, lun 0

<4>scsi : aborting command due to timeout : pid 0, scsi0, channel 0, id 0, lun0

0x00 00 00 00 00 00

<6>(scsi0:0:0:0) SCSISIGI 0xa4, SEQADDR 0x162, SSTAT0 0x0, SSTAT1 0x2

<6>(scsi0:0:0:0) SG_CACHEPTR 0x2, SSTAT2 0x0, STCNT 0x0

<4>SCSI host 0 abort (pid 0) timed out – resetting

<4>SCSI bus is being reset for host 0 channel 0.

<4>SCSI host 0 abort (pid 0) timed out – resetting

<4>SCSI bus is being reset for host 0 channel 0.

<4>(scsi0:0:0:0) Device reset, Message buffer in use

<4>SCSI host 0 channel 0 reset (pid 0) timed out – trying harder…

and so on.. keeps looping.

Machine hardware is Dual Pentium III 600E with 256megs of Ram

Onboard Adaptec AIC-7896 Scsi Bios v2.20S1B1

Scsi Drive – Western Digital WDE18300 Ultra2-LVD (ch a, scsi id 0)

Let me know if you need more information.

서진우

서진우

슈퍼컴퓨팅 전문 기업 클루닉스/ 상무(기술이사)/ 정보시스템감리사/ 시스존 블로그 운영자

You may also like...

페이스북/트위트/구글 계정으로 댓글 가능합니다.